Why not supported Periscope

If your phone is not set Periscope application, it is obvious the system requirements may not match the software.

As for IOS just want to warn that installing Periscope on iPhone 4S and younger should not try.

телефон

If you go to the page Periscope in app store – there clearly will be written iOS 7.1, or a version that came later.
If you have a phone on the Android
Here just about all as well – models of course need only try, but that version of Android can be found in the Google Play Market .
Here, too, all clearly written: Android 4.4 or later. So first of all we compare the version, and then try to install the program.
Eventually
You have in your phone must be at least a minimum of 512 MB of RAM or more – less modern processor.

You may also like...

Do NOT follow this link or you will be banned from the site!